Home > Community > Forums > Custom IC Design > LVS Problem with Artist Flat Netlisting

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 LVS Problem with Artist Flat Netlisting 

Last post Tue, Mar 31 2009 10:19 PM by weiz. 2 replies.
Started by weiz 30 Mar 2009 11:01 PM. Topic has 2 replies and 2396 views
Page 1 of 1 (3 items)
Sort Posts:
  • Mon, Mar 30 2009 11:01 PM

    • weiz
    • Not Ranked
    • Joined on Mon, Jul 14 2008
    • Posts 5
    • Points 100
    LVS Problem with Artist Flat Netlisting Reply

    Hello,

    I encountered a LVS problem a week ago. I searched this forum before I post but I think my LVS problem is unique. Here is a section of the error log

    Begin netlist: Mar 27 11:49:11 2009
    view name list = ("auLvs" "extracted" "schematic")
    stop name list = ("auLvs")
    library name = "test"
    cell name = "inv"
    view name = "extracted"
    globals lib = "basic"
    Running Artist Flat Netlisting ...
    *Error* sh: artcpp: not found

    *Error* in modelPath:
    -Y/n/homeserver2/user2a/mcwang/cadence/LVS/layout 

    When I clicked on the "RUN" button for DivaLVS, the CIW windows said LVS started, but then a pop-up message said the LVS has failed. I checked the error log and posted a portion of it above
    I am especially confounded by this error message; I am not sure what it means

    *Error* sh: artcpp: not found;

    Can anyone please help? I'd greatly appreciate it!

    • Post Points: 20
  • Tue, Mar 31 2009 2:40 AM

    Re: LVS Problem with Artist Flat Netlisting Reply

    artcpp should be in <ICinstDir>/tools/dfII/bin - is it there? Do you have that directory in your UNIX $PATH ?

    Regards,

    Andrew.

     

    • Post Points: 20
  • Tue, Mar 31 2009 10:19 PM

    • weiz
    • Not Ranked
    • Joined on Mon, Jul 14 2008
    • Posts 5
    • Points 100
    Re: LVS Problem with Artist Flat Netlisting Reply

    Thank you very much Andrew. That's exactly what happened. artcpp file was in <ICinstDir>/tools/dfII/bin but I did not set the environment variable in $PATH. After I did that the problem is gone. Thanks again!!!

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by weiz at 30 Mar 2009 11:01 PM. Topic has 2 replies.