Home > Community > Forums > RF Design > Warnings during the use of Spectre

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Warnings during the use of Spectre 

Last post Sat, Jan 4 2014 10:18 AM by Duy Hien. 3 replies.
Started by Starry 04 Mar 2009 05:03 PM. Topic has 3 replies and 9776 views
Page 1 of 1 (4 items)
Sort Posts:
  • Wed, Mar 4 2009 5:03 PM

    • Starry
    • Not Ranked
    • Joined on Thu, Mar 5 2009
    • Davis, CA
    • Posts 2
    • Points 40
    Warnings during the use of Spectre Reply

    Hi~ I am kinda a newbie to Cadence. Don't laugh at me if my questions are stupid :)

    I am using version 5.1.0, and IBM design kits.

    Some warnings come up when I start up cadence. 

    1. Startup:
    *WARNING* No user triggers registered for viewType schematic.
    *WARNING* No user triggers registered for viewType schematicSymbol.
    *WARNING* No user triggers registered for viewType maskLayout.
    What do those mean? How to get rid of this?

    2. When I open the schematic, click any simulation tool, either Analog environment,or ADS dynamic link . It shows:

    *WARNING* ERROR (LM -30): license server ("") does not support feature "34510" (run 'lic_error -30' for more information)
    *WARNING* ERROR (LM -30): license server ("") does not support feature "Analog_Design_Environment_L" (run 'lic_error -30' for more information)

    I check my licenses from "Options", I can only "check out" ("95210     Virtuoso(R) Analog Design Environment XL"), but not ( "34510     Virtuoso(R) Analog Design Environment" . 

    So is this a serious problem? I can still run simulations.

    3.While doing simulation, the following show up:

    spectre (ver. 5.10.41.071008 -- 10 Jul 2008).

    Opening directory
            /tmp2/IBM130/IBM_PDK/cmrf8sf/V1.5.0.1DM/Spectre/models/coupled_cpw.va.ahdlcmi/
            (770)
    Compiling ahdlcmi module library.
    Failed to compile ahdlcmi module library, see
            /tmp2/IBM130/IBM_PDK/cmrf8sf/V1.5.0.1DM/Spectre/models/coupled_cpw.va.ahdlcmi/
            for details
    Could not open ahdlcmi module library
            /tmp2/IBM130/IBM_PDK/cmrf8sf/V1.5.0.1DM/Spectre/models/coupled_cpw.va.ahdlcmi/obj/Linux2.6.18-128.1.1.el5+gcc/optimize/libahdlcmi.so
            /tmp2/IBM130/IBM_PDK/cmrf8sf/V1.5.0.1DM/Spectre/models/coupled_cpw.va.ahdlcmi/obj/Linux2.6.18-128.1.1.el5+gcc/optimize/libahdlcmi.so:
            cannot open shared object file: No such file or directory
    Opening directory
            /tmp2/IBM130/IBM_PDK/cmrf8sf/V1.5.0.1DM/Spectre/models/mvcapdg.va.ahdlcmi/
            (770)

    Created directory input.ahdlcmi/ (770)
    Compiling ahdlcmi module library.
    Failed to compile ahdlcmi module library, see input.ahdlcmi/ for details
    Could not open ahdlcmi module library
            input.ahdlcmi/obj/Linux2.6.18-128.1.1.el5+gcc/optimize/libahdlcmi.so
            input.ahdlcmi/obj/Linux2.6.18-128.1.1.el5+gcc/optimize/libahdlcmi.so:
            cannot open shared object file: No such file or directory

    So, is it because of my version of spectre doesn't support AHDL? How to fix this?

    Thanks!!!

    Filed under:
    • Post Points: 20
  • Wed, Mar 4 2009 9:50 PM

    • skillUser
    • Top 10 Contributor
    • Joined on Fri, Sep 19 2008
    • Austin, TX
    • Posts 2,598
    • Points 16,075
    Re: Warnings during the use of Spectre Reply

     HI,

    For 1), there is a call to the function deUnRegUserTriggers() for each of the viewTypes shown (schematic, schematicSymbol, and maskLayout) - this is likely in a .cdsinit  SKILL syntax file in the home, working or local installation subdirectory. It could also be loaded as part of a library initialization sequence, libInit.il, which is automatically loaded on first access to the library. It is just a warning and can be ignored, though it is not the best programming practice to have code that generates these warnings, I'm sure that they could be avoided. What do these mean? A user trigger would allow you to run a SKILL procedure upon opening a view of the type that the trigger was registered for, it's a handy way to customize every schematic, every symbol and every layout view (in this case).

    For 2) I'm not sure, but perhaps the license daemons are not the most recent? Check the versions of lmgrd and cdslmd running on the license server against the version of software that you are running. I would say that this is problematic and needs to be resolved!

    For 3) I doubt that Spectre doesn't support AHDL/Verilog-A it has been for a long while.  I suspect that the LD_LIBRARY_PATH environment variable does not include the paths required for the AHDLCMI - however I defer to experts here as I don't work with Spectre much.

    Hope this helps you!

    Regards,

    Lawrence.

    • Post Points: 20
  • Fri, Mar 6 2009 4:28 PM

    • Starry
    • Not Ranked
    • Joined on Thu, Mar 5 2009
    • Davis, CA
    • Posts 2
    • Points 40
    Re: Warnings during the use of Spectre Reply

    Hi, Lawrence

    Thanks for your kind help! That was useful!

    I solved my first and third problems, by modifying my .cshrc file. It turns out that I didn't set the right path for MMSIM and Calibre. 

    As for problem 2, I am still bugging the person who is responsible for the licenses. 

    Thank you again!

    Regards

    Huan

    Filed under: ,
    • Post Points: 20
  • Sat, Jan 4 2014 10:18 AM

    • Duy Hien
    • Top 500 Contributor
    • Joined on Tue, Aug 6 2013
    • Posts 24
    • Points 375
    Re: Warnings during the use of Spectre Reply

    Hi Starry,

    I got the simillar warning as you asked:

    *WARNING* (DEBASE-102068): No user triggers registered for viewType schematicSymbol.

    You said that you had solved it. This is the first time I install a pdk on Cadence. Can you describe more detail? Thank in advanced.

    By the way, CIW also warns:

    *WARNING* No application registered for prefix awv.

    *WARNING* No application registered for prefix awv.

    *WARNING* No application registered for prefix awv. 

    It seems that I cannot use bindkeys. Can anyone help me, please? Any advice is fully appreciated.

    Regards.

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by Starry at 04 Mar 2009 05:03 PM. Topic has 3 replies.