Home > Community > Blogs > System Design and Verification > running incisive on ubuntu linux
 
Login with a Cadence account.
Not a member yet?
Create a permanent login account to make interactions with Cadence more convenient.

Register | Membership benefits
Get email delivery of the System Design and Verification blog (individual posts).
 

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

Running Incisive on Ubuntu Linux

Comments(12)Filed under: Incisive, linux, Ubuntu, Virtual Machine, Systemm Design and Verification

Ubuntu is by many accounts the most popular and the easiest to use Linux distribution for the desktop. Unfortunately for Linux enthusiasts, Cadence tends to follow the EDA Industry OS Roadmap when selecting operating systems to support.

I would guess that it's a fairly common problem that users don't want to use one of the two primary Linux platforms, Red Hat Enterprise Linux (RHEL) or SUSE Linux Enterprise (SLES). Most of the time it's because these are not easily available. From time-to-time questions appear on the internal Incisive AE e-mail traffic about clone distributions like CentOS. There are also community options like Fedora and openSUSE that are similar to the "official" EDA operating systems. Personally, I have used openSUSE quite a bit in the past.

Verification engineers probably work on remote machines a fair amount of the time using tools like VNC (I also use TightVNC) and NoMachine NX, but working on the desktop is also a popular use model for many tasks. If you are going to work on a Linux desktop or laptop it seems to make sense to want to try the most popular desktop distribution, Ubuntu.

Today, I have a few tips for running Incisive on Ubuntu. I recently gave it a shot by downloading the Ubuntu 9.10 CD .iso file to my computer. First, I installed VirtualBox to host a Ubuntu Virtual Machine. The Ubuntu installation is very easy since VirtualBox can install directly from the .iso file; there is no need to actually burn a CD-ROM. Ubuntu is also nice because 1 CD takes care of everything and it's very easy to add software later (as we will see). If you have questions on the details of using VirtualBox please feel free to post questions, I'm not going to include all the details here. It probably took about an hour to download and install.

After the Ubuntu installation was complete I went to downloads.cadence.com to get InstallScape, the Cadence software installation tool. I won't document all the details, but it was no trouble to extract InstallScape using:

% uncompress < ~/Downloads/IScape03.71-s001lnx86.t.Z | tar xvf -

and then running it using: 

% iscape/bin/iscape.sh

I installed INCISIV92 as normal. It actually takes a lot longer to install Incisive than Ubuntu so I let it download over night. When the installation ended and I got to the "configuration" step errors had occurred. Some of the shell scripts had failed. Here's the screen shot:

 

Photobucket

 

The first reason the configuration fails is because Ubuntu does not use bash for /bin/sh but instead uses a different shell called dash. The reason for it seems to be mostly about boot speed. Booting fast is good, but Incisive uses a lot of shell scripts which are not compatible with dash. A little reading shows dash is a POSIX compatible shell and while the creators of Ubuntu regret that your scripts might not be POSIX compatible, they feel the solution should be to fix the scripts. Well, I cannot fix all the Cadence scripts (maybe somebody reading this can) so I just avoided the issue altogether by putting /bin/sh back to bash instead of dash as shown in the screen shot below. I guess I have a slower boot time now.

 

Photobucket

 

There is more reason why the configuration fails. There are some scripts using /bin/csh. C-shell is not installed by default on Ubuntu, but it can be easily added using

% sudo apt-get install csh

Now the configuration runs fine.  Here is the result:

 

Photobucket

 

I added a few lines to my .bashrc to setup my PATH and I was ready to give it a try.

I didn't find any issues at all with the ncsim part of Incisive on Ubuntu, everything worked as expected.

A few trials with Specman revealed that specman uses /bin/ksh. This was easily remedied by:

% sudo apt-get install ksh

I also found specman uses /bin/basename which is located at /usr/bin/basename on Ubuntu. Since there are multiple files relying on /bin/basename I decided to not try to edit them but instead make a link to take care of it by going to /bin and doing:

% sudo ln -s /usr/bin/basename basename

The same is true for /bin/sort, on Ubuntu it's located in /usr/bin/sort

% sudo ln -s /usr/bin/sort sort

Here is a screen shot of running the ISX example that is included with Incisive, for those that want to run it use:

% `sn_which.sh ex_gsa_oc_soc_lib`/demo.sh

 

Photobucket

 

In conclusion, just because Incisive is not supported on Ubuntu doesn't mean that it doesn't work. I didn't test everything nor do I claim that Ubuntu is a fully tested and supported platform by Cadence (because it's not), but I have shown that Incisive does work on Ubuntu, the most popular desktop Linux distribution.  If only I could just do

% sudo apt-get install incisive

Oh well, maybe someday.

Probably the worst thing about Ubuntu is the color scheme clash with the Cadence Red scheme. I think my next step is to change the theme so it doesn't hurt my eyes so much. This unsightly mix is probably one of the primary reasons why Ubuntu is rumored to be changing the default colors to something based on gray as the default color scheme.

Jason Andrews

Comments(12)

By Alessandro Ogheri on March 19, 2010
Thanks Jason for your info...
Just my 2 cents to help some people here:
I bought in the past for 2 coworkers of mine 2 laptops and we installed fedora on them, with the hope that probably this would have been a very compatible distribution and that incisive and specman should run pretty fine on it:
ACTUALLY, yes, we were right and on these 2 machines (2 samsung r60plus with 3gb of ram and 250gb harddisk) and using fedora 10 (at this time, it was fedora 10 still...) INCISIVE IUS and SPECMAN did work for us PERFECTLY at the first shot "right out of the box" so to say.
Kind regards,
Alessandro Ogheri

By theASICguy on April 27, 2010
Hi Jason,
As you know, Incisive runs just fine on the Xuropa labs that use CentOS, which is the free RHEL distribution. Because it's so close to RHEL, there are usually very few problems getting labs running.
Harry

By ChonO on April 7, 2011
I hate RHEL..  so behind.  So It was nice to bring up an ubuntu box in my office.  Initially it was just a terminal nice way to serve vnc sessions...  and I had to ssh into the old boxes to run IUS.  But now I have the tools local.  Much faster.
I should note that I still have to fall back on the RHEL4 boxes when I get weird ubuntu behaviour...  but it's still nice to have.
Thanks!
Some updates:
In ubuntu 10.10 64-bit I had to install the 32bit libs to get installscape to run:
sudo apt-get install ia32-libs
And for the lmtools I needed lsb:
sudo apt-get install lsb
I also had to make the changes you mentioned -- installing ksh and csh and adding soft links for sh, basename and sort.
I installed java too - when I was trying to figure out the library issue, but it turns out that it was probably unnecessary.

By Nils on April 27, 2011
I just learned, that to use gcc 4.4, which comes with INCISIV on ubuntu 10.10 or 10.04 you have to remove or rename the following files:
   IUS_INSTALL_DIR/tools/systemc/gcc/4.4-x86_64/install/lib/gcc/x86_64-redhat-linux/4.4.0/include-fixed/features.h
   IUS_INSTALL_DIR/tools/systemc/gcc/4.4/install/lib/gcc/i686-pc-linux-gnu/4.4.0/include-fixed/features.h
Otherwise I ran into weird errors complaining about 'uselocale'.
Now I can even run SystemC designs on Ubuntu!

By Jason on May 17, 2011
If you have strange fonts in simvision try this:
$ sudo apt-get install ttf-mscorefonts-installer

By Leandro Heck on April 5, 2012
I get run incisive on my ubuntu 11.10.
The steps can be seen bellow
#--------------------------------------------------------------------------
# Installing Incisive 11.10.008 on Ubuntu 11.10 64 bits
#--------------------------------------------------------------------------
# Fix default shell
sudo rm -rf /bin/sh
sudo ln -s /bin/bash /bin/sh
# Add required extra shells
sudo aptitude install csh
sudo aptitude install ksh
# Fix missing tools
sudo ln -s /usr/bin/basename /bin/basename
sudo ln -s /usr/bin/sort /bin/sort
sudo ln -s /usr/bin/make /usr/bin/gmake
# Fix missing libraries 32 bits
sudo aptitude install ia32-libs
sudo aptitude install gcc-multilib
# Fix missing libraries 32 bits at wrong places
sudo ln -s /usr/lib32/crt?.o   /lib/
sudo ln -s /usr/lib32/librt.so /lib/librt.so
sudo ln -s /usr/lib32/libm.so  /lib/libm.so
sudo ln -s /usr/lib32/libc.so  /lib/libc.so
sudo ln -s /usr/lib32/libdl.so /lib/libdl.so
sudo ln -s /usr/lib32/libdl.a  /lib/libdl.a
# Fix missing license managment tools (lmtools)
sudo aptitude install lsb
# Fix wrong fonts
sudo aptitude install ttf-mscorefonts-installer
#--------------------------------------------------------------------------
# Workaround for "uselocales"
#--------------------------------------------------------------------------
# At compilation if appear an error message about uselocales
#export INSTALL_PATH=(INSISIVE_PATH)
#export H1_PATH=${INSTALL_PATH}/tools/systemc/gcc/4.4-x86_64/install/lib/gcc/x86_64-redhat-linux/4.4.0/include-fixed
#export H2_PATH=${INSTALL_PATH}/tools/systemc/gcc/4.4/install/lib/gcc/i686-pc-linux-gnu/4.4.0/include-fixed
#sudo mv ${H1_PATH}/features.h ${H1_PATH}/features.h.removed
#sudo mv ${H1_PATH}/features.h ${H1_PATH}/features.h.removed
#--------------------------------------------------------------------------
# To test
#--------------------------------------------------------------------------
# Load environment
export CDS_INST_DIR=(INSTALATION_PATH)
# Binaries path
export PATH=${PATH}:${CDS_INST_DIR}/bin
export PATH=${PATH}:${CDS_INST_DIR}/tools/bin
# License
export LM_LICENSE_FILE=...
export CDS_LIC_FILE=...
# Running demo
`sn_which.sh ex_gsa_oc_soc_lib`/demo.sh

By Reza on November 8, 2012
Jason,I downloaded the iscaqpe and unpack it. When I try to run " iscape/bin/iscape.sh" under ubuntu gives me error can't find Java. Do I need to set a default path or need to download Java? I am new to linux.Thanks, R

By jasona on November 9, 2012
Reza, yes, you will need Java. I use OpenJDK, to install run $ sudo apt-get install openjdk-7-jre

By Reza on November 9, 2012
Jason, I was able to install icapse and install incisive. when I try the demo `sn_which.sh ex_gsa_oc_soc_lib`/demo.sh, I get      sn_which.sh: command not found
bash: /demo.sh: No such file or directory  Thanks, R

By Reza on November 10, 2012
Jason, Would you know how to manually install and configure the software once the tars are downloaded rather using icapse? icapse download is very slow. Also, the base software has multiple tar files like "Base_INCISIV12.10.001_lnx86_1of10.tar". Do I need to untar each one, or the untar software takes care of it automatically? In Window Winrar  takes care of it automatically, since the files are connected. Is this true for tar downloads, also?Thanks,R

By Reza on November 29, 2012
Jason,
Any idea why my INCISIV configuration fails. I am installing on 32bits ubuntu. The logfile shows two errors as in partial list:
thx,
Reza
Running:/bin/sh /home/reza/cadence/installs/INCISIV121/install/tmp/slconfig.sh pcm101_config12.10-s004
Error::Return Value is:1
Running:/bin/sh /home/reza/cadence/installs/INCISIV121/install/tmp/slconfig.sh pcm102_config12.10-s004
Error::Return Value is:1

By Jason Andrews on December 10, 2012
Reza,
It loks like shell scripts are failing. The most common cause to make sure you are using bash instead of dash, make sure you do: $ sudo dpkg-reconfigure dash  I have a newer blog that may help, search the Cadence community for "Ubuntu Updates 2012".
Good luck,
Jason

Leave a Comment


Name
E-mail (will not be published)
Comment
 I have read and agree to the Terms of use and Community Guidelines.
Community Guidelines
The Cadence Design Communities support Cadence users and technologists interacting to exchange ideas, news, technical information, and best practices to solve problems and get the most from Cadence technology. The community is open to everyone, and to provide the most value, we require participants to follow our Community Guidelines that facilitate a quality exchange of ideas and information. By accessing, contributing, using or downloading any materials from the site, you agree to be bound by the full Community Guidelines.